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Version: 2023.3

Unable to Add Resources

Description

The user is unable to perform one or both of the following: 

  • Add resources to blueprints.
  • Add a new script via the Manage dashboard.

Possible Causes

CloudShell is installed in a High Availability configuration.

WebDAV is enabled under the IIS on the CloudShell Portal machine.

Solution

Important

If you’re working in High Availability mode, perform these steps on both CloudShell Portal nodes.

To resolve the issue described above, follow these steps:

  1. On the CloudShell Portal machine, click Start > Programs and Features > Turn Windows features on or off
  2. Under Internet Information Services > World Wide Web Services > Common HTTP Features > ensure that WebDav Publishing is unchecked.
  3. Restart CloudShell Portal:
    1. Launch the IIS Management console.
    2. Click the CloudShell website.
    3. Click Restart under the Manage Website section on the right.
      note

      Restarting the website will disconnect all logged in users.

Configure the Self-Service Portal