The Create Blueprint Link is Missing From the Blueprint Catalog
Description
The + Create Blueprint link is missing from the Blueprint Catalog, preventing users from creating blueprints.
Possible Causes
- The domain's Topologies folder has been removed from Resource Manager Client.
- The
OnlyAllowNewEnvironmentsFromTemplates
key is enabled on the server but there are no templates in the domain.
Solution
To set a new Topologies folder to the domain:
-
In Resource Manager Client, open Resource Explorer.
-
Add a new folder.
-
In the Domains explorer, double-click the domain and switch to the Properties page.
-
Click the Change button to the right of the Topologies Folder field and select the new folder.
-
Click OK.
To fix the missing templates issue:
- Open the
C:\Program Files (x86)\QualiSystems\CloudShell\Server\customer.config
file and make sure theOnlyAllowNewEnvironmentsFromTemplates
key is included and set to True. - In CloudShell Portal, go to the Manage>Blueprint Templates page and make sure at least one template is associated with the domain.