MSDTC Security Configuration
Error Message
Description
When running the Quali Server configuration wizard, and trying to connect to a database in the Database selection screen, an error message is displayed if there is a security configuration issue.
Possible Causes
Possible reasons for incorrect MSDTC configuration include:
- MSDTC is not installed.
- MSDTC is not configured to start automatically in Windows Services.
- Security configurations of MSDTC are not correctly defined.
To run the CloudShell Suite applications, configure MSDTC Security settings on the Quali Server machine and the SQL database machine (or machines in a High Availability deployment).
Solution
To resolve the issue described above, follow these steps:
- Ensure that proper Security Settings in Local DTC properties have been selected:
- Go to Control Panel > Administrative Tools > Component Services or select Start > Run, type dcomcnfg.exe and press Enter.
- From the left navigation tree, drill down to Component Services > Computers > My Computer > Distributed Transaction Coordinator > Local DTC.
- Right click Local DTC and select Properties from the context menu.
In the Security tab, select the following checkboxes:
- Network DTC Access
- Allow Remote Client
- Allow Remote Administration
- Allow Inbound
- Allow Outbound
- Enable SNA LU 6.2 Transactions
- No Authentication Required
- Apply the changes and click OK. The service restarts. However, you may have to restart the computer(s).
- For all operating systems, define the Distributed Transaction Coordinator service to startup automatically:
- Select Start > Run, type services.msc and press Enter.
- In the Services window, right-click Distributed Transaction Coordinator, and select Properties from the context menu.
- In the Startup type dropdown list, select Automatic.
- Click OK to close the Properties window.